Windows-Probleme

Aus BotE Wiki
Wechseln zu: Navigation, Suche

Englisch-Symbol.jpg for English just click here

Unter Windows kann es (durch die Benutzerverwaltung und fehlenden Rechten) zu folgenden Problemen kommen:

! Programm als Administrator ausführen !

Einige Probleme können verhindert bzw. umgangen werden, wenn das Spiel als Administrator ausgeführt wird.


Hierfür Rechts-Klick auf das Programmsymbol->Eigenschaften->Kompatibilität-> Haken bei "Programm als Administrator ausführen"

oder: nur Rechtsklick->"als Administrator ausführen" (je nach UserAccountControl(UAC)-Einstellung bei Windows)


BotE ausführen ohne UAC-Abfrage

Ein Starten ohne (lästige) UAC-Aufgabe ist mit folgendem Trick möglich, der auch hier nachlesbar ist. Der Trick ist ausführlich beschrieben, dauert geht aber schnell!

  • "Aufgabenplanung" starten
  • Rechtsklick auf Aufgabenplanungsbibliothek und neuen Ordner "Meine Tasks" anlegen
  • Einfache(!) Aufgabe erstellen ("einfache"=Schritt für Schritt-Abfrage) im Ordner "Meine Tasks"
  • Name "Birth of the Empires" vergeben
  • beim Start des Computers (wird später deaktiviert)
  • Aktion: "Programm starten", hierbei unter "Starten in" den Pfad ohne BotE.exe angeben/einkopieren
  • Programm-Datei auswählen über Durchsuchen
  • Fertigstellen
  • Rechten Mausklick auf den Task
  • Deaktivieren (also nicht bei jedem Start des Computers, außer das wird gewollt :-))
  • Eigenschaften öffnen
  • unter ALLGEMEIN: Mit höchsten Prioritäten ausführen
  • für Notebooks unter BEDINGUNGEN: bei Energie die Ausführung nur mit Netzkabel deaktivieren


  • auf den Desktop wechseln
  • Rechtsklick->Neue Verknüpfung
  • unter Speicherort eintragen: c:\windows\system32\schtasks.exe /RUN /TN "Meine Tasks\Birth of the Empires"
  • im nächsten Screen den Namen vergeben (bei mir: Task Birth of the Empires, apropos: /TN steht für TaskName)
  • Fertigstellen
  • Rechtsklick auf die Verknüpfung + Eigenschaften wählen + Anderes Symbol wählen + über Durchsuchen das Symbol aus BotE.exe auswählen


  • voila

Problems at Online Gaming

just see here

Meldung "Failed to open LOG File"

Wenn diese Meldung kommt (gleich nach dem Doppelklick auf das Programmsymbol), dann das Spiel als Administrator ausführen.

Alternativ kann die Meldung auch ignoriert werden: Das Spiel erzeugt bei jedem Spielstart automatisch eine Log-Datei. Kann diese nicht erstellt werden, funktioniert das Spiel trotzdem.

bote.ini - "access denied/Zugriff verweigert"

Deutsch-Symbol.jpg bote.ini - "Zugriff verweigert" Englisch-Symbol.jpg bote.ini - "access denied"

Kann die Bote.ini nicht direkt bearbeiten werden, auch hier "als Administrator" bearbeiten. Ein alternativer Lösungsansatz ist hier beschrieben.

If Bote.ini can't be modified directly, please also use "run as administrator". Another method is descripted here.

Connection to client lost

Deutsch-Symbol.jpg "Connection to client lost" Englisch-Symbol.jpg "Connection to client lost"

"Connection to client lost" eine nützliche Info, wenn während des Spiel die Verbindung getrennt wird.

Da BotE auch im SinglePlayer-Modus über Netzwerkcode die Informationen zwischen den sechs Hauptrassen austauscht (z.B. Verträge oder auch, wer welche Rasse spielt), erscheint diese Meldung auch, wenn "zurück" geklickt wird im Choose Race-Fenster zurück zum Start Game-Fenster.

"Connection to client lost" is informs if during the game connection is lost.

Due to BotE uses also in single player mode network code to exchange info between the six major races (like treaties or who plays which race), this message also appears going "back" from Choose Race to Start Game.

Kein Sound

  • liegt die Datei fmodex.dll im BotE-Stammverzeichnis (wie die Bote.exe) ?
  • Auch hier das Programm "als Administrator" (siehe oben) ausführen.
  • versuchen, mal eine der Sounddateien (*.ogg) direkt aufzurufen, ob und wie der PC dieses Format abspielt
  • Aufruf von sndvol.exe (über z.B. nach WIN+R)

Probleme mit der Galaktischen Karte

[nur für alte Versionen, mittlerweile behoben] Hier gibt es immer mal wieder Probleme - es hilft, den Zoom der Karte kurz zu ändern (Mausrad oder Bild-auf/ab-Tasten).

Schiffsgrafik verschwindet

[nur für alte Versionen, mittlerweile behoben] Ab und zu verschwindet die Schiffsgrafik im Detailbereich, taucht dann aber wieder auf. Näheres im Forum http://birth-of-the-empires.de/phpBB3/viewtopic.php?f=64&t=1598.

could not create minorrace

[nur für alte Versionen, mittlerweile behoben]

Wenn die MinorDensity zu hoch eingestellt wird, kommt es zur Fehlermeldung "could not create minorrace".

Lösung 1: ca. bei max. 60% Minor Density kommt es nicht zu Fehlern.

Lösung 2: einfachen auf der ENTER-Taste bleiben, bis die letzte Meldung weg ist - Spiel startet dann


Hintergrund:

Dafür müsste irgendwann der Generierungsalgorithmus geändert werden, dann würde es auch weiterhin funktionieren. Bisher geht der Generierungsalgorithmus die Systeme zeilenweise von links oben nach rechts unten durch. Bei sehr vielen Systemen und hoher Minorracedichte sind die vorhandenen 140 Minors schon verbraucht, bevor er am letzten System angekommen ist. Wenn er dann Minorraces anlegen will, diese aber schon verbraucht sind, kommt der Warnhinweis. Dabei wird keine Rasse angelegt. Dies hat insofern einen Nachteil für die Spieler, die sich weiter rechts unten auf der Map befinden. Diese haben dann einfach keine Minors in ihrer Umgebung. Man müsste den Algorithmus dahingehend verändern, dass er jeden Sektor einmal betrachtet, die Auswahl der Sektoren aber zufällig ist.


EDIT 12.04.2011 - mit Alpha 6.1 behoben:

Der Generierungsalgorithmus wurde überarbeitet. Die Minors sind nun komplett gleichmäßig verteilt über der Map. Wenn keine Minors mehr vorhanden sind, dann wird stattdessen ein normales System generiert. Der Algorithmus verarbeitet die Sektoren aber nun komplett zufällig, so dass keine Position auf der Map irgendwelche deterministischen Vorteile hätte. Wenn überhaupt keine Namen mehr zur Verfügung stehen, dann bekommt der Sektor den Namen "Sektor X/Y" wobei X und Y die Koordinaten sind.

Datei Bote.log - WARNING Could not load graphic

siehe BotE.log


Schriftarten korrekt installiert ?

Schriftarten siehe Fonts - diese sollten korrekt installiert sein

Problem with Windows 7 when running in compatibility mode Win98

nagor reported (search entry en_t=4646) that BotE crashes when saving or loading a save game file. So better don't use compatibility mode Win98.

Problem Windows 7 [solved with running in compatibility mode XP]

see http://forum.birth-of-the-empires.de/viewtopic.php?f=32&t=2340 (search entry t=2340) ("Alpha7 startet nicht unter win7 32bit")

no auto.sav-files ?

(Win7, Win8) -> just run BotE in compatibility mode XP (not Vista, not Win98), see also http://forum.birth-of-the-empires.de/viewtopic.php?f=74&t=2464 (search entry t=2464)

Anderes

Sollte das Spiel fehlerhaft oder gar nicht funktionieren und dein Problem hier nicht aufgeführt sein, solltest du dein Problem im Bug-Forum posten.